Search


Leading developer of retail and pharmacy software

Software Requirements

  • Operating System Requirements 

    Toniq software runs on Microsoft Windows. Professional or Business versions of Windows are required.

    64 bit versions of Windows are a requirement for new machines, from January 2019 onwards.

     

    Toniq will not be able to provide our usual support levels if the Windows installation is not in English.

     

    The following operating systems are supported:

    • *Windows 10 64 bit, Professional or Enterprise
    • *Windows 8.1 Pro or Ent (preferably 64 bit)
    • Windows 7 - End of support in January 2020
    • Windows Server 2016
    • Windows Server 2012 and 2012 R2
    • Windows Server 2008 R2

     

     

    * Check that printer drivers are availalbe for all printers to be used, particularly older Till Receipt printers.

     

    * Windows 10 only supports Microsoft SQL Server 2012 or later.  If you have a paid edition of SQL Server, check the version with your hardware supplier or Toniq to ensure it is compatible.

     

    * Microsoft SQL Server 2016 and above will only run on 64 bit systems.  This means that the server and at least some backup computers must be 64 bit

     

    Click here for Computer & Hardware Requirements

  • MS SQL Server for Toniq Database 

    Toniq uses Microsoft's SQL Server software for database management, which improves database stability.  Express versions of MS SQL are acceptable (within Microsoft limitations such as database size).

     

    The same version of SQL Server must be installed on at least one other computer as a backup server. More are highly recommended.

     

    The version of SQL Server must be either:

    • MS SQL Server 2017 - requires 64 bit Windows and at least Windows 8.1 (Recommended)
    • MS SQL Server 2016 - requires 64 bit Windows and at least Windows 8.1
    • MS SQL Server 2014
    • MS SQL Server 2012 - minimum version supported on Windows 10
    • MS SQL Server 2008 R2 (legacy only)
    • MS SQL Server 2008 (legacy only)
    • MS SQL Server 2005 (legacy only)

     

     

    Each version of SQL Server has its own Operating System requirements:

    SQL Server 2005 - Windows XP up to Windows 7

    SQL Server 2008 and SQL Server 2008 R2 - Windows XP SP2 or later

    SQL Server 2012 - Windows Vista SP2 or later

    SQL Server 2014 - Windows 7 SP1 or later

    SQL Server 2016, 2017- Windows 8.1 or later, 64 bit only

  • Support Software 

    To allow access by Toniq staff for support purposes, all Toniq installs come with remote connection software called Toniq Helpdesk. This allows customers to connect a Toniq staff member directly into any workstation which has an internet connection. Only works for broadband users.

  • Antivirus / Firewall Software 

    It is recommended that you use antivirus AND firewall software on ALL workstations.

     

    Windows contains the Windows Firewall, which is sufficient for most needs when enabled on a computer with antivirus software.  The Toniq program installation configures the Windows Firewall to allow the Toniq programs to run correctly.

     

    More complex firewalls may require extra configuration by your hardware supplier, to get Toniq working.